United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] North Dakota DMV is Offline
Incident Report for Checkr US Data Status
Resolved
07/22/2021: The North Dakota online DMV is back online and MVRs will now be completed.
Posted Jul 22, 2021 - 14:29 UTC
Monitoring
07/21/2021: The North Dakota online DMV is still offline and MVRs are unavailable in the state. We will continue to monitor this.
Posted Jul 21, 2021 - 19:48 UTC
Identified
07/19/20221: The North Dakota online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Jul 19, 2021 - 17:15 UTC