United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Alabama DMV Planned Outage 4/15-4/26
Incident Report for Checkr US Data Status
Resolved
Maintenance is complete and MVRs are now processing.
Posted Apr 22, 2022 - 14:16 UTC
Update
A reminder that Alabama's DMV will be offline beginning tomorrow Friday, April 16 until Tuesday, April 26. Orders that are placed during this window will be held until service is restored.
Posted Apr 14, 2022 - 16:39 UTC
Identified
04/05/2022: The Alabama online DMV plans to have an extended outage starting 4/15- 4/26. Any orders that are requested during this time will not be completed.
Posted Apr 05, 2022 - 20:11 UTC