United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Nevada DMV is Offline
Incident Report for Checkr US Data Status
Resolved
09/13/2021: The NV DMV is back online and MVRs are now processing normally. MVRs held due to the outage should be fulfilled within the next three hours.
Posted Sep 13, 2021 - 21:43 UTC
Monitoring
09/10/2021: The Nevada DMV is still offline and MVRs are unavailable in the state. We will continue to monitor this and notify you of any changes.
Posted Sep 10, 2021 - 20:32 UTC
Identified
09/07/2021: The Nevada online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Sep 07, 2021 - 16:29 UTC