United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Montana DMV is offline
Incident Report for Checkr US Data Status
Resolved
10/21/20: The Montana DMV has recovered from its outage. MVR service has returned to normal activity.
Posted Oct 21, 2020 - 15:50 UTC
Identified
10/20/20: The Montana DMV is experiencing server issues and MVRs are not currently available. The DMV has not yet provided an ETA on when it expects to restore service.
Posted Oct 20, 2020 - 19:49 UTC