United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] MA County Courts Closed
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 06, 2022 - 19:06 UTC
Update
11/1/2021: The Massachusetts online court system is back online, but please expect delays across the state. We will continue to monitor the MA online system and in-court closure status.
Posted Nov 01, 2021 - 16:26 UTC
Update
10/29/2021: The statewide online court system is currently offline and all searches in MA are unable to be completed. Unfortunately, there is currently no ETA of when this will be back online, but we will continue to monitor these major events happening in Massachusetts.
Posted Oct 29, 2021 - 15:45 UTC
Monitoring
10/28/2021: MA courthouses in Barnstable, Norfolk, and Plymouth remain closed and without power. We will continue to monitor this.
Posted Oct 28, 2021 - 20:09 UTC
Identified
10/27/2021: Due to power outages and downed lines and trees across southern/southeastern Massachusetts, some courts have been decided to close. MA courts in Barnstable, Bristol, Dukes, Nantucket, Norfolk, and Plymouth courts are closed today. We currently do not have an ETA of when these will be back open but will continue to monitor this and notify you of any changes.
Posted Oct 27, 2021 - 18:53 UTC