United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] White Pine, NV
Incident Report for Checkr US Data Status
Resolved
07/13/2021: The White Pine, NV system is back online and searches can now be completed.
Posted Jul 12, 2021 - 19:30 UTC
Identified
07/09/2021: The White Pine, NV Court is currently inaccessible to the court clerks, and ALL searches are unable to be completed at this time. The online system is an older model and their IT team is having difficulty locating the needed parts to fix it. Unfortunately, we do not have an ETA at this time. We are in communication with the courts and will continue to monitor this.

*This will affect all searches*
Posted Jul 09, 2021 - 15:30 UTC