United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Possible Cases out of Solano, CA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 01, 2021 - 19:29 UTC
Update
03/29/2021: We received a more detailed explanation of the delays in Solano, CA. When our researchers find a possible hit, they must submit their requests to the clerks for any hard files on cases filed prior to 2018, which is causing the delays to continue. All cases filed since 2018 are readily available on the online index. The clerks do not accept rush requests. They will not alter the order of requests or accommodate any plea from the Researcher Community.

We will continue to monitor any changes to the courts and update you here. *Please note that this delay does not affect clear results, only searches with possible cases.*
Posted Mar 29, 2021 - 17:11 UTC
Update
03/10/2021: There are no changes to the Solano, CA court's status, and there will still be delays to searches with possible cases.
Posted Mar 10, 2021 - 20:38 UTC
Monitoring
02/25/2021: There have been no changes in Solano, CA and we are still seeing delays from the courts. *Please note that this delay does not affect clear results, only searches with possible cases.*
Posted Feb 25, 2021 - 16:24 UTC
Identified
ETA: Unknown

01/25/2021: The courts are now closed. The courts have large backlogs, and they notified our researchers that they do not have the resources to process what they have and are not prioritizing background checks as a whole. The researchers will work to complete the background checks as quickly as they are able.

*Please note that this delay does not affect clear results, only searches with possible cases.*
Posted Jan 26, 2021 - 18:08 UTC