COVID Court Closures and General Delays
Incident Report for Checkr Data Status
Update
We are continuing to monitor for any further issues.
Posted Dec 08, 2021 - 22:41 UTC
Update
12/08/2021: There are new COVID closures. Updated delays in Washington, DC, and Fayette, GA counties are listed below.
Posted Dec 08, 2021 - 22:12 UTC
Update
12/01/2021: There are new COVID closures. Please see the new updates made to county delays below.
Posted Dec 01, 2021 - 21:07 UTC
Update
11/24/2021: There are new COVID closures. Please see the new updates made to county delays below.
Posted Nov 24, 2021 - 20:47 UTC
Update
11/17/2021: There are new COVID closures.
Posted Nov 17, 2021 - 21:21 UTC
Monitoring
Closed Counties:
N/A

Delayed Counties:
--AR - All counties across the state are experiencing delays due to spikes in COVID cases and understaffing at the courts. In Washington County, District court searches must be completed by the clerks. The court is short-staffed. Please expect delays.
--El Dorado, CA - Searches must be conducted by clerks, please expect delays until the online index is back up and running. The online index is expected to be offline until the first of the year, but we will continue to monitor this and notify you of changes.
--Mariposa, CA - The requests must be completed by the clerks, please expect delays.
--CT - The courts across the state of Connecticut are seeing significant delays due to the court clerk's backlogs and record verifying process. Please note that the majority of clear searches should be completed quickly, but expect candidates with potential records to take 2 weeks or longer to complete. We will continue to monitor this and notify you of any changes.
--**Washington, DC - The clerks are limiting how many appointments the researchers can make, please expect delays.
--Baldwin, GA - The court is limiting how many appointments the researchers are allowed to make. Expect delays.
--Clayton, GA - There is very limited access to the courts at this time. Expect major delays.
--**Fayette, GA - The courts are limiting how many appointments the researchers can make, please expect delays.
--Fulton, GA - Many searches require files to be pulled to get complete information. Please expect delays as the researchers navigate court restrictions.
--Cook, IL - The entire research community has lost capacity in Cook, IL due to staffing issues among several of the largest researchers servicing the county. Checkr is working with local researchers to increase capacity and improve turnaround time. Please expect delays for the foreseeable future.
--Harrison, MS - Researchers are seeing delays due to the clerks.
--Carbon, MT - Searches must go through the clerk, please expect delays.
--Lewis and Clark, MT - Searches must be conducted by clerks. The court is operating with limited staff. Please expect delays.
--Silver Bow, MT - Searches must be conducted by clerks. The court is currently backlogged with requests. Please expect delays.
--Yellowstone, MT - The courts have limited appointments for our researchers to 1 hour. Please expect delays.
--Pershing, NV - The court is short-staffed due to COVID, and all District court searches need to be completed by the clerks.
--Davidson, TN - Searches with older possible cases require files to be pulled. Files can only be pulled by the clerks who are not in the court every day. Expect delays.
--Shelby, TN - Searches with older possible cases require files to be pulled. The file pull process is cumbersome and slow. Please expect delays.
--Lubbock, TX - Complete information on possible hits can only be obtained in the courthouse. The court is limiting how frequently researchers can visit. Expect delays.

**New Closure or Delay
Posted Nov 15, 2021 - 19:07 UTC