United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Harris, TX County Searches
Incident Report for Checkr US Data Status
Resolved
04/07/2022: The Harris, TX online court system is back online, and researchers are now able to complete searches.
Posted Apr 07, 2022 - 17:09 UTC
Identified
04/05/2022: The online index is experiencing issues in Harris, TX that are causing delays on all searches. The court's IT team is aware of the issue and is working on a resolution, but there is no ETA at this time. We will continue to monitor the situation and will alert you of any changes.
Posted Apr 05, 2022 - 16:57 UTC