United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 16:30 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend:

Saturday, 9/24
Tennessee: 6-9am PT

Saturday, 9/24 to Sunday, 9/25
Arizona, North Carolina, New Hampshire: 11pm-6am PT

Sunday, 9/25
Illinois: 12-3am PT
Pennsylvania: 12-6am PT
Texas: 5-10am PT
Minnesota: 7-9am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Sep 23, 2022 - 16:14 UTC