United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] King, WA
Incident Report for Checkr US Data Status
Resolved
The King, WA online case management system has been updated. King, WA county searches and WA state searches can once again be completed. Please continue to expect delays while we work through the backlog.
Posted Mar 28, 2022 - 16:31 UTC
Identified
The King, WA online case management system is currently undergoing an update. No searches can be completed until the online website has been updated. The court is expected to fix the issue by Monday, March 28th.

Please note that the outage in King, WA also affects WA state searches. No WA state searches can be completed until the King, WA online site has been fixed. We will continue to monitor the situation and notify you of any updates.
Posted Mar 23, 2022 - 18:44 UTC