United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Montana DMV Maintenance: 6/29-6/30
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 22:53 UTC
Identified
The Montana DMV is conducting maintenance and will be unavailable on Wednesday, June 29 and Thursday, June 30. We expect service to resume on Friday, July 1. During the maintenance window, MVRs will not be available in the state.
Posted Jun 27, 2022 - 21:40 UTC