United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Harrison, MS
Incident Report for Checkr US Data Status
Resolved
9/29/2020: The Harrison, MS court has reopened. Please expect delays as we work through the backlog.
Posted Sep 29, 2020 - 18:28 UTC
Identified
Expected Fix Date: TBD

9/14/2020: Harrison, MS is currently closed due to tropical storms.
Posted Sep 14, 2020 - 21:06 UTC