United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Pennsylvania DMV is offline
Incident Report for Checkr US Data Status
Resolved
PA is back online and MVRs are now processing normally.
Posted Jul 05, 2022 - 13:49 UTC
Identified
The Pennsylvania DMV is offline and MVRs are not unavailable in the state. We have reached out to the state but, given the holiday, we do not anticipate hearing back until Tuesday, July 5. We will provide updates as they become available.
Posted Jul 04, 2022 - 18:15 UTC