United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New Jersey DMV is Offline
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 19, 2021 - 15:47 UTC
Identified
4/16/21: The New Jersey DMV is offline and MVRs in the state are not currently available. Checkr is in contact with the DMV but the state is not currently able to provide an ETA for a resolution.
Posted Apr 17, 2021 - 00:33 UTC