United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New Hampshire Server Outage
Incident Report for Checkr US Data Status
Resolved
06/07/2021: The power was restored to New Hampshire's servers on Friday, 06/04. Searches have been completing since then. This outage is now resolved.
Posted Jun 07, 2021 - 20:40 UTC
Identified
06/03/2021: A construction crew working at the NH courthouse accidentally severed the power lines to the building that houses the servers that the entire state's court system runs on and is unable to complete any searches. They are working to restore power and get the system back up and running, but there is currently no ETA. We will continue to monitor this and stay in contact with the courts.

*This will affect all searches within the state of New Hampshire*
Posted Jun 03, 2021 - 20:40 UTC