United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] South Carolina Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 20:14 UTC
Identified
05/05/2021: South Carolina's online index has been experiencing some technical issues this week which are causing delays. Our researchers are working to fix this issue and completing reports as quickly as possible. We will continue to monitor this.

*This will only affect reports with possible cases*
Posted May 05, 2021 - 17:46 UTC