[Planned Outage] Florida DMV Scheduled Maintenance
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 18:08 UTC
Identified
The Florida DMV will be performing scheduled maintenance today from 4-9pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Jan 24, 2023 - 22:07 UTC