[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 17:11 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times on Sunday, 11/20:

Pennsylvania: 12-6am PT
Rhode Island: 4:30-6am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Nov 18, 2022 - 17:47 UTC