United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] TN and OK DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 01, 2022 - 15:48 UTC
Identified
The following DMVs will be performing scheduled maintenance today at these times:

Tennessee: 2:30-4:30pm PT
Oklahoma: 6-9pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Oct 31, 2022 - 16:07 UTC