United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Temporary Closure] Idaho DMV
Incident Report for Checkr US Data Status
Resolved
10/12/20: The DMV maintenance was completed as scheduled. There are no further delays related to Idaho MVRs.
Posted Oct 12, 2020 - 21:08 UTC
Identified
10/9/2020: The Idaho DMV is undergoing system maintenance and Idaho MVRs will not be available until at least the evening of Sunday, October 11.
Posted Oct 09, 2020 - 21:25 UTC