[Delay] Possible Cases Coweta, GA
Incident Report for Checkr Data Status
Resolved
04/07/2021: The Coweta, GA county courts are back open.
Posted Apr 07, 2021 - 15:23 UTC
Identified
ETA: Unknown

03/30/2021: Coweta, GA court is closed due to structural damage received during last week's storms. Our researchers confirmed they are able to complete most searches, but pulling older cases might cause delays until the court re-opens. We will continue to monitor this.

*This will only affect reports with possible cases*
Posted Mar 30, 2021 - 20:22 UTC