United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Massachusetts County Searches
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Mar 28, 2022 - 18:07 UTC
Update
The courthouses in MA are open today and searches can once again be completed. However, our researchers are continuing to experience system slowdowns that are hurting their productivity. They continue to work with the court to try to resolve the issues as soon as possible, but there is no ETA at this time.
Posted Feb 28, 2022 - 18:23 UTC
Monitoring
All courthouses in MA are closed today due to a winter storm. In addition, our researchers continue to experience system slowdowns throughout the state. They are working with the court to try to resolve the issues, but there is no ETA at this time. We will keep you posted with any new developments.
Posted Feb 25, 2022 - 16:53 UTC
Identified
02/10/2022: MA online index has been experiencing some technical issues, which are causing delays. Our researchers are working to fix this issue and completing reports as quickly as possible. We will continue to monitor this.
Posted Feb 10, 2022 - 20:14 UTC