United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Closures due to Winter Storms
Incident Report for Checkr US Data Status
Resolved
1/10/2022: Courts affected by the storms have reopened. Please expect delays as the researchers complete searches.
Posted Jan 10, 2022 - 23:41 UTC
Update
1/7/2022: Additional counties have been affected by the winter storms and decided to close. Some are expected to open on Monday, but we will monitor this and update you as we know more.

Closures/Delays:
MA
KY
WV
TN
Washington, DC
DE - Kent, New Castle, Sussex
Posted Jan 07, 2022 - 21:58 UTC
Monitoring
01/07/2022: Various county courts across the US are currently closed due to the Winter Storms. Several of these courts are either closed or are not accessible due to dangerous driving conditions. We will continue to monitor this and notify you of any changes.

Closures/Delays:
All MA
All KY
Clay, TN
Posted Jan 07, 2022 - 16:14 UTC