United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Palm Beach, FL
Incident Report for Checkr US Data Status
Resolved
12/21/2021: The Palm Beach, FL online index is functioning once again and our researchers are able to complete searches.
Posted Dec 21, 2021 - 18:48 UTC
Monitoring
12/15/2021: The Palm Beach, FL online index is still experiencing delays on searches with possible records. We will continue to monitor this and notify you of any changes. *Estimate of impacted reports: 0.8%*
Posted Dec 15, 2021 - 21:13 UTC
Identified
12/08/2021: The Palm Beach, FL online index is experiencing delays on searches with possible records. We are in contact with the courts, but there is currently no ETA for when this will be fixed. Please expect delays on searches with possible cases, clear searches are returning as normal. *Estimate of impacted reports: 1%*
Posted Dec 08, 2021 - 18:46 UTC