United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Maryland DMV is Offline
Incident Report for Checkr US Data Status
Resolved
Maryland DMV is back up and processing.
Posted Feb 17, 2021 - 15:36 UTC
Identified
02/16/2021: The Maryland DMV is experiencing an outage and MVRs in the state are currently unavailable. We do not currently have an ETA, but will be monitoring this issue.
Posted Feb 16, 2021 - 23:39 UTC