United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New Jersey DMV is offline
Incident Report for Checkr US Data Status
Resolved
Service has been restored as of 5 PM on 02/08/2021 and New Jersey MVRs are now processing normally.
Posted Feb 09, 2021 - 01:31 UTC
Identified
2/8/21: The New Jersey DMV is experiencing an outage and MVRs in the state are currently unavailable. We do not currently have an ETA, but they are expecting this to last at least a few hours.
Posted Feb 08, 2021 - 17:17 UTC