United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Various Counties in GA, KY, and MT
Incident Report for Checkr US Data Status
Resolved
11/17/2020: The only outstanding county on this closure update is Menifee, KY, which is still closed, but not due to the election. The county is unfortunately in the “red zone” for new COVID cases. No searches can be completed until the court reopens. Please use this link to track KY courts that are closed due to rising COVID cases: https://courts.checkrstatus.com/.
Posted Nov 18, 2020 - 00:56 UTC
Monitoring
11/4/2020: Please see below for an update on the delays and closures in GA, KY, and MT.

Hall, GA: The PAT has been restored and researchers are working through the backlog.
Carter, KY: The public access terminal in the court has been repaired. Researchers are able to conduct full criminal research once again.
Menifee, KY: The court is still closed. No searches can be completed until the court reopens.
Hill, MT: The court has installed the new software and researchers are working through the backlog.
Posted Nov 04, 2020 - 23:26 UTC
Identified
Expected Fix Date: TBD

10/29/2020: Please see below for a list of delays and closures in GA, KY, and MT.

Hall, GA: The court PAT is not fully functional at this time. As a result, searches with possible records will be delayed. Clear searches can still be completed as normal.
Carter, KY: The public access terminal in the court is down with no ETA on when it will be repaired. No searches can be completed until the public access terminal is restored.
Menifee, KY: The court will not allow any access this week while they are setting up for the election. No searches can be completed until the court reopens.
Hill, MT: The court is installing new software. No searches can be completed until the installation is done.
Posted Oct 29, 2020 - 23:49 UTC