United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Possible Cases out of Dekalb, GA
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 18, 2021 - 19:33 UTC
Identified
Current ETA: June 7th, 2021

05/10/2021: The Dekalb, GA county courts are not allowing access at this time. Reports that require our researchers to pull files from the courts cannot be completed at this time. The courts provided a current estimated ETA for 06/07, but we will continue to monitor this.

*This will only affect reports with possible cases*
Posted May 10, 2021 - 20:13 UTC