United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] North Dakota DMV is offline
Incident Report for Checkr US Data Status
Resolved
The North Dakota DMV is back online and MVRs are now processing.
Posted Apr 18, 2022 - 15:01 UTC
Identified
4/15/2022: The North Dakota DMV is offline and MVRs cannot currently be completed. We are in contact with the state and we will provide updates on when to expect service to be restored as they become available.
Posted Apr 15, 2022 - 22:47 UTC