United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] KY Courts Affected by COVID
Incident Report for Checkr US Data Status
Resolved
04/15/2021: The majority of KY Courts have opened back up and running. There will likely still be some delays, depending on the courts' restrictions put in place for the researchers. To see any courts that are still closed due to COVID, you can visit https://courts.checkrstatus.com/.
Posted Apr 15, 2021 - 20:31 UTC
Identified
Expected Fix Date: TBD

11/5/2020: On Monday, November 2nd the Kentucky Chief Justice put out an emergency order requiring all "red zone" counties to shut down court hearings and other non-essential in person services. This is a result of a color coding system the state has implemented for each county based on the number of new COVID cases. There are four possible colors - green, yellow, orange, and red - with green being the least amount of new cases and red being the highest amount. At this point in time, over half of Kentucky counties are in the “red zone.” However, our researchers have observed that this doesn’t necessarily mean that all “red zone” counties are closed. Similarly, researchers have observed that there may be limited access in some “green zone” counties. This is because each county is determining whether or not to allow public access, which so far has varied greatly by county.

The Chief Justice’s emergency order has no indication as to the length of time that courts are required to be closed. As such, this entire week our researchers have been trying to obtain as much information from the courts to prepare for the potential impact. However, the court's next status update may not be available until Monday, November 9th.

We are tracking all Kentucky court closures here: https://courts.checkrstatus.com/. The website will be updated as we become aware of new closures. Please make sure to check the website for updates on which Kentucky counties are closing and reopening.

A map of all of the zones in Kentucky can be viewed here: https://govstatus.egov.com/kycovid19
Posted Nov 05, 2020 - 22:20 UTC