[Outage] NC DMV is Offline
Incident Report for Checkr Data Status
Resolved
The NC DMV is back online and MVRs are now being processed.
Posted Jul 26, 2022 - 20:29 UTC
Monitoring
The NC DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Jul 26, 2022 - 16:20 UTC