United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Virginia DMV is offline
Incident Report for Checkr US Data Status
Resolved
03/23/22: The VA DMV is back online and MVRs are processing normally.
Posted Mar 24, 2022 - 03:13 UTC
Identified
03/23/22: The Virginia DMV is offline and MVRs are not available. We are in communication with the state and will provide updates as they become available.
Posted Mar 24, 2022 - 02:16 UTC