United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Closure - Franklin, NY
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 11, 2022 - 16:30 UTC
Monitoring
06/24/2022: The Franklin, NY county court will NOT be conducting criminal and civil searches from June 24th to July 8th. This is due to the staffing shortages they are expecting to have during the July 4th holiday. We will continue to monitor this. Estimated Reopening - Monday, July 11, 2022. *Impact Unknown*
Posted Jun 24, 2022 - 20:51 UTC