United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Michigan DMV is Offline
Incident Report for Checkr US Data Status
Resolved
07/27/2021: The Michigan DMV is back online and orders are able to be processed.
Posted Jul 27, 2021 - 18:24 UTC
Identified
07/26/2021: The Michigan online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update as we learn more.
Posted Jul 26, 2021 - 22:31 UTC