United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New Jersey DMV is Offline
Incident Report for Checkr US Data Status
Resolved
7/17/2021: Service has been restored in NJ and MVRs are now processing normally.
Posted Jul 17, 2021 - 22:07 UTC
Identified
07/16/2021: The New Jersey DMV is currently offline and MVRs are not available in the state. We are in communication with the state and will provide updates as we receive them.
Posted Jul 16, 2021 - 22:05 UTC