United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Henry, GA
Incident Report for Checkr US Data Status
Resolved
11/24/2021: The Henry, GA online system is back online and orders are able to be processed.
Posted Nov 24, 2021 - 17:25 UTC
Monitoring
11/15/2021: The Henry, GA online system is still down and orders are only able to be processed by an in-court researcher. We will continue to monitor this delay and keep you updated. *Estimated number of reports affected - .11%*
Posted Nov 15, 2021 - 19:26 UTC
Identified
10/27/2021: The Henry, GA online system is currently down and orders are only able to be processed by an in-court researcher. Please expect major delays. There is no ETA of when this will be back up, but we will continue to monitor this. *Estimated number of reports affected - .19%*
Posted Oct 27, 2021 - 16:55 UTC