United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Weather Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 22:25 UTC
Monitoring
02/22/2021: There are still weather delays in the following states: KY, LA, MS, TN, and TX. Additional jurisdictions could be affected, but this is all we have been notified of at this point.
Posted Feb 22, 2021 - 21:09 UTC
Identified
ETA: Unknown

02/18/2021: Due to the weather conditions and power outages across the United States, we are seeing court delays in the following states and counties:

Majority of KY, LA, MO, MS, TN, TX, WV
OH: Harrison
MI: Covington, De Soto, Forrest, Lamar, Lawrence, Lee, Marshall

Additional jurisdictions could be affected by these storms, but this is all we have been notified of at this point. We will continue to monitor this and notify you of any additional or prolonged closures.
Posted Feb 18, 2021 - 21:39 UTC