United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Drug Screening Delays - Alere Lab Louisiana
Incident Report for Checkr US Data Status
Resolved
09/08/2021: The Gretna Alere Laboratory has restored power and operations. They will be working 24/7 shifts over the coming days to get caught up and thru the backlog of specimens. From collections 8/27 forward, expect reporting delays until they are caught up.
Posted Sep 08, 2021 - 20:00 UTC
Identified
09/03/2021: Due to Hurricane Ida’s impact on the Alere Laboratory in LA, lab drug screening times maybe be delayed 1-2 business days. We will continue to monitor this and keep you updated.
Posted Sep 03, 2021 - 17:59 UTC