[Outage] Florida DMV Planned Maintenance - Friday, Nov 6
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 17:19 UTC
Identified
The Florida DMV will be offline for maintenance on Friday, November 6 from approximately 7pm until shortly after 12am Eastern. FL MVRs will not be available during this time.
Posted Nov 05, 2020 - 17:20 UTC