[Outage] Georgia DMV is Offline
Incident Report for Checkr Data Status
Resolved
11/24/2021: The Georgia DMV is back online and orders are able to be processed.
Posted Nov 24, 2021 - 22:53 UTC
Identified
11/24/2021: The Georgia online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update as we learn more.
Posted Nov 24, 2021 - 20:47 UTC