United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Arkansas DMV Maintenance 11/10-11/13
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 17:41 UTC
Identified
The Arkansas DMV will be performing scheduled maintenance starting on Thursday, November 10 at 9:20pm PT and ending on Sunday, November 13 at 9:10am PT. MVRs ordered during this time will not be available. Please note that MVRs will be processed once service is restored.
Posted Nov 08, 2022 - 17:51 UTC