United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Santa Barbara, CA Furlough
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 02, 2021 - 17:21 UTC
Identified
Expected Fix Date: 1/4/2021

12/18/2020: The Santa Barbara court has closed for furlough through the end of the year. At this time, the court plans to reopen at the beginning of the year. Clear searches will continue to process as usual, searches with possible records will be delayed until the court reopens.
Posted Dec 18, 2020 - 22:55 UTC