United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Massachusetts DMV is Offline
Incident Report for Checkr US Data Status
Resolved
04/27/2021: The Massachusetts DMV is back online.
Posted Apr 27, 2021 - 13:59 UTC
Identified
4/26/21: The Massachusetts DMV is currently offline and MVRs in the State are not currently available. Checkr is in contact with the DMV but we do not currently have an ETA for a resolution.
Posted Apr 26, 2021 - 16:26 UTC