United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Tennessee DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 18:33 UTC
Identified
The Tennessee DMV will be performing scheduled maintenance today from 6:30-8:30pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Jan 25, 2023 - 18:09 UTC