United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Henry, KY
Incident Report for Checkr US Data Status
Resolved
09/27/2021: The Henry, KY courthouse has opened in their new location and searches will now be conducted.
Posted Sep 27, 2021 - 16:55 UTC
Identified
09/17/2021: The Henry, KY courthouse is moving locations beginning on Monday, September 20th. They are expected to open the new location on September 27th. All searches will be affected and none will be completed during this time.
Posted Sep 17, 2021 - 20:37 UTC