United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Jefferson, KY
Incident Report for Checkr US Data Status
Resolved
10/13/2020: The Jefferson, KY court reopened the week of 9/28/2020 and has been open with restrictions ever since. Please be aware that there are *severe* delays in the county due to extremely limited capacity. Our researchers are still only able to access the court via appointment because of COVID precautions. These appointments are only once or twice a week and are for no longer than 2 hours. In addition, there are only two PATs available to use in court. The courts are not sharing any estimate on when they think the restrictions will be lifted and our researchers have not yet had any breakthroughs on how to increase their capacity within the courts. Please continue to expect severe delays on any pending Jefferson, KY searches.
Posted Oct 13, 2020 - 23:48 UTC
Monitoring
9/30/2020: Jefferson, KY has reopened and our researchers have been able to secure appointments for the week. They noted that the barricades around the courthouse are back up, which may be an indication that the courts are planning on closing again. Our researchers are monitoring the situation and will alert us of any changes. At this time, the court is open and they are using their appointments to complete as many searches as possible.
Posted Sep 30, 2020 - 16:52 UTC
Investigating
9/22/2020: Due to potential civil unrest regarding the announcement of the Breonna Taylor case, the mayor has declared a state of emergency for Louisville, KY. The courts have closed for the remainder of the week, cancelling any court appointments our researchers and vendors had scheduled. No searches can be completed at this time.
Posted Sep 22, 2020 - 17:58 UTC