[Outage] Arizona DMV is Offline
Incident Report for Checkr Data Status
Resolved
The Arizona DMV is back online and MVRs are once again processing as normal.
Posted Dec 21, 2022 - 18:56 UTC
Monitoring
The AZ DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Dec 21, 2022 - 17:28 UTC