United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] DMV Delays - Multiple States
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 06, 2021 - 14:32 UTC
Monitoring
05/05/2021: California, Colorado, and Indiana are back up and running. We are still seeing delays out of New Jersey, and we will continue to monitor this.
Posted May 05, 2021 - 22:35 UTC
Identified
05/05/2021: There are significant delays for MVRs on the following DMV sites: California, New Jersey, Colorado, and Indiana. We are working with the state on these sites and will continue to keep you updated as they are back up and running.
Posted May 05, 2021 - 19:24 UTC