United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Alabama DMV Scheduled Maintenance: 11/11
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 17:49 UTC
Identified
Due to scheduled maintenance, the Alabama DMV will be offline on Wednesday, Nov. 11 from 5am until 1:30pm Pacific. Alabama MVRs will be unavailable during this time.
Posted Nov 10, 2020 - 17:11 UTC